[solved]V4.1b9 shuts down


Posting rules: It shouldn't need saying, but... play nice. Please keep your discussions civil. You can disagree, just don't be disagreeable. And, of course, all of the usual stuff like no spamming. Tex adds: I'll be rigorously enforcing this as we go along. We're probably going to be a small community in a little lifeboat, so we can't have members at each others' throats. This is for the sake of the project as a whole. So when you post, pretend you're speaking in person with your very wealthy auntie who has always treated you wonderfully and currently lists you prominently in her will. I won't be tossing anyone out of the forums because we are all in this together (except spammers: immediate membership cancelation), but I'll delete suspect posts right away.


22 posts / 0 new
Last post
krist8
[solved]V4.1b9 shuts down

I have been using beta9 for the last 2 days, including this morning, with no problems.  But, after lunch, beta9 refuses to go into raw edit mode.  It just shuts down.  I tried to update  my system and re-install, but no help. 

I am using debian testing.  Any idea where the error log is?  /var/log/dmesg annd syslog do not show anythinf relating to LZ.

krist8
error message in /tmp

Here is part of the error message in /tmp

#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fd0b7581efb, pid=5776, tid=140531831019264
#
# JRE version: OpenJDK Runtime Environment (7.0_55-b14) (build 1.7.0_55-b14)
# Java VM: OpenJDK 64-Bit Server VM (24.51-b03 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C  [libjava.so+0x18efb]  Java_java_nio_Bits_copyToShortArray+0x1fb
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#

I do not know what caused it.  It was working ok this morning.

There is also this very dark frame in /tmp

/tmp/LZRAWTMP1604030674408135958.ppm

krist8
I think my problem is somehow

I think my problem is somehow related to dcraw which I downloaded separately and had run it onece to create a .tif conversion.  I re-installed my debian jessie, and all is fine now.

 

edit: I spoke too soon.  The first raw conversion is ok.  The second one shuts down LZ.

krist8
Since I am not getting much

Since I am not getting much help here, I have taken another painfull action.  I installed Debian wheezy (stable) and LZ is running ok.  But, my normal debian is jessie (testing) in which LZ cannot do edit of raw files.  It seems that LZ is not tested in jessie? Can any one in the know respond pleaase, or am I in the wrong thread?

tex
You're not in the wrong

You're not in the wrong thread, necessarily.  You're just in a volunteer outfit.  That means support is going to be spotty.  I know nothing about Linux, so although i've seen your posts, I had nothing i could offer as help.

 

I think Masahiro is very busy right now---as am I (and i will be until the fall at least...)

sfink16
Jessie Not Listed

in supporting list of distributions, see -> https://github.com/ktgw0316/LightZone/wiki/Installation%20instructions%2...

 

 

krist8
Thanks TEX and SF for your

Thanks TEX and SF for your responses.  I'll use debian stable, although it means rebooting, but it is ok, and I do not have to keep wondering if there is something wrong with my jessie installation.

hansemann
I got the same problem on

I got the same problem on debian unstable, I'm relative shure that it is not a lightzone problem. Lightzone has always run very good on debian even the beta9. I think the problem is a update somewhere in the java engine on debian....I try to check it.

 

.......the openjdk-7-....... has been updated on debian unstable and testing around the time your problems start.

regards hans

krist8
Thanks, Hanse.  That explains

Thanks, Hanse.  That explains why it did work for a week.

hansemann
I've downgraded the openjdk-7

I've downgraded the openjdk-7 packages to the last version and lightzone works like a charme again.....

regards

krist8
Is this the package?

Is this the package?

openjdk-7-dbg_7u55-2.4.7-2_amd64.deb on AMD64 machines

But, I already have it installed.

 

hansemann
No, you don't need this

No, you don't need this package.

I have 4 different openjdk-7 packages on my system

1. openjdk-7-jdk

2.openjdk-7-jre

3. openjdk-7-jre-headless

4. openjdk-7-jre-lib

I don't know which one was the faulty but I would expect that it is one of the jre's (java run time enviroment) files.

I switched back from the packages with the version number 7u55-2.4.7-2 to packages with the version number 7u55-2.4.7-1 - this was the previous version. You can find this version in the stable tree. The problem could be, if you get automatic updates, that apt always install the newer files again. 

I try to get all my english together and make a bug report to the package maintainer.

regards hans

krist8
Thanks for your help.  I have

Thanks for your help.  I have removed the -2 version and installed the -1 version, and it works.  I'll do the same if it happens in the next update.

hansemann
You might want to change the

You might want to change the package "icedtea-7-jre-jamvm" too.

I've noticed that there is a incorrect dependency while checking something with synaptic.

this package belongs to the other 4,it is build from the same sourcepackage (openjdk-7) and should have the same versionnumber as the other 4. after doing so, the error message in synaptic is gone. If you update your system with synaptic you should be able to set the 5 packages at hold, so they would not be updated every time.

 

hans

krist8
Thanks Hans.  Somehow all

Thanks Hans.  Somehow all five packages were downgraded for me automatically.  Now I have them pinned.  Just found out how to do it.  Thanks.

saedelaere
I just came accross this

I just came accross this topic. I have the same problem on archlinux with openjdk/jre 7.u60_2.5.0-2

I can't open any raw files as Lightzone instantly crashes when I try to do so:

Checking cache for: /home/saedelaere/BilderNessstation/IMGP2465.DNG
File not in cache.
metadata width: 4352, height: 2868
dcraw value: 0
#
# A fatal error has been detected by the Java Runtime Environment:
#
# SIGSEGV (0xb) at pc=0x00007fa407debbab, pid=5246, tid=140341874890496
#
# JRE version: OpenJDK Runtime Environment (7.0_60-b30) (build 1.7.0_60-b30)
# Java VM: OpenJDK 64-Bit Server VM (24.60-b09 mixed mode linux-amd64 compressed oops)
# Problematic frame:
# C [libjava.so+0x18bab] Java_java_nio_Bits_copyToShortArray+0x1fb

I was able to downgrade to 7.u55_2.4.7 which works without issues. Should I file a bug on github for lightzone or is this a openjdk/jre problem?

tex
Yes please

I think you should definitely file a bug on Github!  It may not be an LZ problem, but even if it isn't we'll need to deal with it...

hansemann
Till now I thought it was a

Till now I thought it was a debian specific problem with the newest version of openjdk, but after your report it seems that something has changed in the sourcecode.

If there are no bugreports from other software packages regarding this, it may be an upcomming problem with lightzone and will increase abruptly if the next ubuntu (etc) versions will come out.

I don't know what to do....

duky
Wotks fine with Oracle proprietary jre

Just for information, I've had the same poblem on my debian testing too.

So I've tried with the Orcle jre environment and it works fine.

Here a link on how install Oracle jre on Debian:

https://wiki.debian.org/JavaPackage

hansemann
On Debian unstable is now a

On Debian unstable is now a new version of openjdk-7 (Version number: 7u65-2.5.1-4)

This version works with Lightzone again :) .....so I think the problem is finaly gone

Lbs6r
Hello.

Hello.

I experienced a simlar problem in Ubuntu 14.10 with Lightzone 4.0.0.

Lightzone would crash when asked to edit raw files, outputting an error similar, but not identical to

# Problematic frame:
# C  [libjava.so+0x18efb]  Java_java_nio_Bits_copyToShortArray+0x1fb
#

I installed Lightzone version 4.1.0~beta13 and now all appears well in 14.10!

Previously I had been using Ubuntu 14.04 and 4.0.0 without issue, but was forced to upgrade to 14.10 to support new hardware.

It's much less of a headache to be a little bit behind the times, I think.

masjak
Crash

Hi there ! 

First time using Lightzone, but... it doesn't. Crash occurs everytime I try to import a picture. Here is the error in the terminal.

 

jacques@Archie:~>  lightzone    
Starting LightZone version 4.0.0 ...
with options :
This is LightZone 4.0.0 ()
Verifying Libraries
Initializing Engine Utilities
Max Memory: 1789919232
Total Memory: 60293120
Running on 4 processors
Allocating -556MB for the image cache.
Loading Classes
Scanning Color Profiles
Restoring Preferences
Starting Logging
Scanning Saved Documents
Opening...
Light Crafts JAI Library - 02/05/07
dcraw value: 0
Read 8294400 bytes in 81ms
dcraw value: 0
Read 8294400 bytes in 45ms
dcraw value: 0
dcraw value: 0
Read 8294400 bytes in 78ms
Read 8294400 bytes in 47ms
dcraw value: 0
Read 8294400 bytes in 51ms
Template error: Couldn't access Template "CameraDefault;PANASONIC DMC-LX100" in /home/jacques/LightZone/Templates: /home/jacques/LightZone/Templates/CameraDefault;PANASONIC DMC-LX100.lzt (Aucun fichier ou dossier de ce type)
Opening /home/jacques/Desktop/temp/P1000058.RW2
Checking cache for: /home/jacques/Desktop/temp/P1000058.RW2
File not in cache.
metadata width: 4128, height: 3104
dcraw value: 0
#
# A fatal error has been detected by the Java Runtime Environment:
#
#  SIGSEGV (0xb) at pc=0x00007fe24eb79b2b, pid=4752, tid=140608003991296
#
# JRE version: OpenJDK Runtime Environment (7.0_75-b13) (build 1.7.0_75-b13)
# Java VM: OpenJDK 64-Bit Server VM (24.75-b04 mixed mode linux-amd64 compressed oops)
# Derivative: IcedTea 2.5.4
# Distribution: Custom build (Fri Jan 23 11:00:44 UTC 2015)
# Problematic frame:
# C  [libjava.so+0x18b2b]  Java_java_nio_Bits_copyToShortArray+0x1fb
#
# Failed to write core dump. Core dumps have been disabled. To enable core dumping, try "ulimit -c unlimited" before starting Java again
#
# An error report file with more information is saved as:
# /tmp/hs_err_pid4752.log
#
# If you would like to submit a bug report, please include
# instructions on how to reproduce the bug and visit:
#   http://icedtea.classpath.org/bugzilla
# The crash happened outside the Java Virtual Machine in native code.
# See problematic frame for where to report the bug.
#
/usr/bin/lightzone : ligne 35 :  4752 Abandon                 (core dumped)( cd "/opt/lightzone" && LD_PRELOAD="$lzmalibrary" LD_LIBRARY_PATH="/opt/lightzone" exec java -Xmx${maxmem}k -Djava.library.path="/opt/lightzone" -Dfile.encoding=UTF8 -classpath "/opt/lightzone/*" com.lightcrafts.platform.linux.LinuxLauncher ${@} )