libgomp.so.1 GOMP_4.0 not found


Posting rules: It shouldn't need saying, but... play nice. Please keep your discussions civil. You can disagree, just don't be disagreeable. And, of course, all of the usual stuff like no spamming. Tex adds: I'll be rigorously enforcing this as we go along. We're probably going to be a small community in a little lifeboat, so we can't have members at each others' throats. This is for the sake of the project as a whole. So when you post, pretend you're speaking in person with your very wealthy auntie who has always treated you wonderfully and currently lists you prominently in her will. I won't be tossing anyone out of the forums because we are all in this together (except spammers: immediate membership cancelation), but I'll delete suspect posts right away.


18 posts / 0 new
Last post
orlcam88
libgomp.so.1 GOMP_4.0 not found

Hi,

 

   I just installed Lightzone 4.1 and I get a message saying DCRaw requires GOMP_4.0 not found.  I believe the version I have of libgomp.so.1 is not the right version?  I see it exist so that's what threw my conclusion.

I installed in Mint release 17 Kernel Linux 3.13.0.24-generic , MATE 1.8.1.  I selected the latest version of Ubuntu to do the installation.  

   The software starts up afterwards and I played around with a photo to see if I can edit it and I can.

 I'm not sure how to get this updated.  

Any help would be appreciated.

Thank you.

greerd
Hi orlcam88

The only installed GOMP on my Mint 17.1 is libgomp1, ver. 4.8.2-19ubuntu1.

Also, Mint 17 is based on Ubuntu 14.04 LTS, so using the latest opensuse.org lightzone (xbuntu 15.05) install repo might not be the best bet. Mine is set to xbuntu 14.04.

Doug

orlcam88
thank you Doug.  I'll remove

thank you Doug.  I'll remove the version I have an use the Ubuntu 14.04.

alexk4
Hi orlcam88,

Did you solve the problem?

I installed the latest Lightzone 4.1.1 and also got the same error message about GOMP_4.0 from DCRaw. I founf that 'libgomp.so.1' file is exist in '/usr/lib/x86_64-linux-gnu/' directory.

Could it be a lib version problem?

fotoforce2156
I had same problem but resolved it

I had the same problem and error message after installing Lightzone 4.1.1-0obs1 direclty from the Linux Mint software manager on Linux Mint 17.1 Cinnamon 64-bit, 3.13.0-37-generic kernel. Software started fine but I could not edit any RAW (DNG) files. I also tried uninstalling and re-installing (from the software manager), but to no avail.

As suggested, I installed a version of LZ for Ubuntu 14.04 from the ppa. LZ now works fine.

Thanks.

 

lore68
Same problem on LinuxMint Debian Edition

I Installed LZ 4.1.2 on my LinuxMint Debian Edition (Jessie based) following the Debian instructions, but I have the same problem.

Searching for libgomp library in my system, I found:

/usr/lib/x86_64-linux-gnu/libgomp.so.1 -> libgomp.so.1.0.0
/usr/lib/x86_64-linux-gnu/libgomp.so.1.0.0

Can anyone help me?

Thanks,

Lorenzo

greerd
Hi Lore68

I am not familiar with LMDE, but from what I've read it's based on debian testing while LMDE 2 is based on Jessie. Are you using LMDE 2?

I also have the same libgomp's as you but mine have (according to synaptic) updated from libgomp1 4.8.4-2ubuntu1 to libgomp1 4.8.4-2ubuntu1~14.04 since my earlier entry in the thread. Guess that doesn’t help much on debian though.

Sorry I can't be more help,
Doug

Serge Schmitt
same libgomp problem

Kubuntu 14.04 I used 14.04 on the Suse repository. No more work :-((

Is there another ppa ?

In order to continue working, can somebody give me a link to version 4.0 for reinstalling it ? Or send me the deb  to sersch@gmail.com.

It's the first time in years I deleted the older dowloaded deb...

Thanks in advance!

Serge Schmitt
same libgomp problem + libjpeg

Hoping it it helps, I removed and purged lightzone then reinstalled.

It does'n't install any libgomp file.

Alas I get a supplementary warning:

/usr/lib/lightzone/libLCJPEG.so: libjpeg.so.62: Ne peut ouvrir le fichier d'objet partagé: Aucun fichier ou dossier de ce type. 'cannot open shared object file: No such file or directory)

Any help ?

greerd
Hi Serge

I have /usr/lib/lightzone/libLCJPEG.so, but libjpeg.so.62 is installed in /usr/lib/x86_64-linux-gnu/.

My libjpeg62 is version 6b1-4ubuntu1.

Doug

Serge Schmitt
same libgomp problem

Hello Doug!

Thanks fot the help.

The libjpeg62 problem seems to be solved, but not the libgomp1 one.

I'm on 14.04 and if I try to install it, that says me that le latest one is already installed. Idem for dcraw.

The message is :

/usr/lib/lightzone/libDCRaw.so: /usr/lib/x86_64-linux-gnu/libgomp.so.1: version `GOMP_4.0' not found (required by /usr/lib/lightzone/libDCRaw.so)

 A libgomp is here, as on said by lore68 (message #6) but version 4.8.2-19ubuntu1

As a consequence, I can edit and save jpeg images, but no raw ( "file format is not recognized" and "unsupported camera ".).

I can also edit my already done lzn files, with all modifications.

Serge

greerd
Hi Serge

In my comment #7, I made an error, the libgomp1 version I had at the time of my comment #2 was as you have now, 4.8.2-19ubuntu1. I believe that was for Lightzone 4.1.1.

Now with Lightzone 4.1.2, I have libgomp1 ver 4.8.4-2ubuntu1~14.04. I don't know if this is the problem and I also don't know why yours hasn't updated.

Just to add to my list of unknowns, I'm not sure if purging lightzone will actually delete the contents of /usr/lib/lightzone. (as one would assume)

Just 'clutching at straws' here.

ktgw0316
Hi,

Hi,

 

The 4.8.2-19ubuntu1 is from trusty repo, while the 4.8.4-2ubuntu1~14.04 is from trusty-updates repo, though I'm not sure that the version difference is the cause of the problem since LZ v4.1.2 for 14.04 was built using 4.8.2-19ubuntu1 of libgomp1. Library dependency is always a pain in the neck. :(

 

Serge, could you add the trusty-updates repo in your /etc/apt/sources.list and check if it works after apt-get update ?

https://help.ubuntu.com/lts/serverguide/configuration.html

 

Masahiro

Serge Schmitt
libgomp1 problem

Hi Masahiro,

Those trusty-updates repos were still in my sources list. (main, restricted, universe, multiverse).

I also still had 4.8.4-2ubuntu1~14.04 version of libgomp1, synaptic says.

Nevertheless I attempted an update, hope keeps us alive, but no change occured.

Serge

t-legiaw
please try to use lightzone for Debian 7.0

Obviously the Ubuntu Versions of  /usr/lib/lightzone/libDCRaw.so are linked against a newer version of libgomp.so. So it cannot find the required 4.0 symbols. Only the older 3.x Symbols are there.

Purging Lightzone and reinstalling with "LightZone for Debian 7.0"  will probably fix it.

 

roc97007
getting same gomp_4.0 error (Mint 17.3 Rosa)

I'm getting the same errors described by others with Mint -- GOMP_4.0 not found and Couldn't link with native library: "fbf

version 'GLIBCXX_3.4.21 not found'

I tried both the Ubuntu and Debian installs (in that order).

Has anyone got this working under Mint?  I don't have much time invested in Lightzone so far -- could easily try one of the other packages like Darktable.  But if there's a known solution, I'm willing to try it.

zosimas
I tried installing from the

I tried installing from the 14.04 instructions (after completely removing the first attempt) and am getting DCRaw library error version GOMP 4.0 not found. 

va3pinner
I got it working

Running Linux Mint 17 with all updates. Installed manually from the Ubuntu 15. __ instructions and got three errors: Could not link with DCRaw, FastJAI, and FBF libraries. Lightzone would open, but had no effect on photos. I used Synaptic Package Manager and did a complete uninstall, and refreshed it. Then went back to the installation and reinstalled for Ubuntu 14.04. First couple of edits seem to be working OK, will play around with it and post back with confirmation. Yep, an hour later fooling around with it and it seems to be working OK with this installation. Should have noted I'm working with panasonic raw and jpeg files.