Internal Error (Java error?)


Posting rules: It shouldn't need saying, but... play nice. Please keep your discussions civil. You can disagree, just don't be disagreeable. And, of course, all of the usual stuff like no spamming. Tex adds: I'll be rigorously enforcing this as we go along. We're probably going to be a small community in a little lifeboat, so we can't have members at each others' throats. This is for the sake of the project as a whole. So when you post, pretend you're speaking in person with your very wealthy auntie who has always treated you wonderfully and currently lists you prominently in her will. I won't be tossing anyone out of the forums because we are all in this together (except spammers: immediate membership cancelation), but I'll delete suspect posts right away.


6 posts / 0 new
Last post
sfink16
Internal Error (Java error?)

Hello All,

 

I've been running LZ for some time now but recently I have encountered a new "Internal Error" when attempting to start the software.  Uninstalling and installing fresh from the authorized site doesn't help.  I had just OpenJRK 7 installed and now tried installing OpenJRK 6 as well.  That didn't work so I uninstalled version 6, leaving 7 there.  I see LZ and 2 versions of apparently the same Java running when I view System Monitor.  Here are the details of the crash:

 

java.lang.NoSuchMethodError: org.jvnet.lafwidget.menu.MenuSearchWidget.showSearchPanels()V
at org.jvnet.substance.SubstanceMenuBarUI.showSearchPanels(SubstanceMenuBarUI.java:88)
at org.jvnet.substance.SubstanceLookAndFeel.initialize(SubstanceLookAndFeel.java:3932)
at javax.swing.UIManager.setLookAndFeel(UIManager.java:535)
at org.jvnet.substance.SubstanceLookAndFeel.setSkin(SubstanceLookAndFeel.java:4996)
at com.lightcrafts.ui.LightZoneSkin.getLightZoneLookAndFeel(LightZoneSkin.java:295)
at com.lightcrafts.platform.linux.LinuxPlatform.getLookAndFeel(LinuxPlatform.java:58)

at com.lightcrafts.platform.linux.LinuxLauncher.main(LinuxLauncher.java:36)

 

Am I using the wrong Java?  I can't seem to figure this one out.  Any help would be appreciated.  Thanks!

 

Steve

larshenrikoern
What platform

Hi

 

It seems you running Linux. Is this correct ?? And what distribution and version of your operating system.

 

Is your oprerating system 64 or 32 bit. Is your inststallation java the same (64 bit LightZone will not work with 32 bit, and 32 bit not on 64 bit).

At the moment on Linux Lightzone 4.1.4 requieres from from Sun to run. So I am myself not able to run LightZone because I want to use open software only. But you might try yourself with Sun.

 

Have a nice day

ktgw0316
If you are using Debian,

If you are using Debian, Ubuntu or Mint Linux, try:`

sudo apt-get update

sudo apt-get install liblaf-widget-java

sudo apt-get dist-upgrade

 

Hope this helps,

 

Masahiro

larshenrikoern
Hi Masahiro

Hi Masahiro

Gave the following error on Debian Testing

 

java.lang.NoSuchMethodError: org.jvnet.lafwidget.menu.MenuSearchWidget.showSearchPanels()V
    at org.jvnet.substance.SubstanceMenuBarUI.showSearchPanels(SubstanceMenuBarUI.java:88)
    at org.jvnet.substance.SubstanceLookAndFeel.initialize(SubstanceLookAndFeel.java:3932)
    at javax.swing.UIManager.setLookAndFeel(UIManager.java:535)
    at org.jvnet.substance.SubstanceLookAndFeel.setSkin(SubstanceLookAndFeel.java:4996)
    at com.lightcrafts.ui.LightZoneSkin.getLightZoneLookAndFeel(LightZoneSkin.java:295)
    at com.lightcrafts.platform.linux.LinuxPlatform.getLookAndFeel(LinuxPlatform.java:58)
    at com.lightcrafts.platform.linux.LinuxLauncher.main(LinuxLauncher.java:36)

 

 

So no luck with this. But something happend Before the gui was starting but could not load any image for processing. Now the gui is not starting, except for an startup error.

 

By the way. I have updated and corrected some errors in my danish translation of LightZone. So they are ready when you need them.

 

Have a nice day

sfink16
Same error on my Ubuntu 14.04

Sorry Masahiri but I should have mentioned that I'm using Ubuntu 14.04.  I executed the commands above but did not have success.  BTW, last I checked the LZ is working on my Win 10 device.  It looks like I'm 32-bit instead of 64-bit.  Not sure why I installed it that way but I did.  It's  dual boot Win 10/Ubuntu 14.04 that came with Win 7 64-bit.  I am pasting my terminal session for you to hopefully see where the problem is.  I'll indent below the horizontal line.

 

Thanks!

 

Steve

 

Old log stuff removed since it is now irrelevant. 

sfink16
UPDATE: LZ Works Under Upgraded Ubuntu 15.10 64-bit

I have since upgraded my PC to Ubuntu 15.10 (Wily) 64-bit and reloaded LZ (latest) and it works fin now.  Unfortunately the upgrade did cost my dual boot Ubuntu/Windows 10.  Somehow I was left with Ubuntu 15.10 and Windows 7 (original OS of the PC).  This is not a big deal to me since I have another desktop with windows 10 on it.

 

Steve