Beta 10 does not complete startup


Posting rules: It shouldn't need saying, but... play nice. Please keep your discussions civil. You can disagree, just don't be disagreeable. And, of course, all of the usual stuff like no spamming. Tex adds: I'll be rigorously enforcing this as we go along. We're probably going to be a small community in a little lifeboat, so we can't have members at each others' throats. This is for the sake of the project as a whole. So when you post, pretend you're speaking in person with your very wealthy auntie who has always treated you wonderfully and currently lists you prominently in her will. I won't be tossing anyone out of the forums because we are all in this together (except spammers: immediate membership cancelation), but I'll delete suspect posts right away.


28 posts / 0 new
Last post
berbmit
Beta 10 does not complete startup

I am running Mint 17, and lightzone beta 9 was working fine.  Beta 10 became available and I upgraded and lightzone failed to install.  So I did an apt-get purge and clean install of beta 10.  Now it starts with the request panel saying lightzone failed to start and would I like to reset settings.  Whethere I choose reset or not, it then continues to the main screen which flashes up for less than a second with a smaller alert window ... but it disappears before one can read it and lightzone crashes.   Any help much appreciated.

The trace is as follows:

Starting LightZone version 4.1.0 beta10 ...
with options :
This is LightZone 4.1.0~beta10 ()
Verifying Libraries
Initializing Engine Utilities
Max Memory: 7462191104
Total Memory: 251658240
Running on 8 processors
Allocating 0MB for the image cache.
Loading Classes
Scanning Color Profiles
Restoring Preferences
Starting Logging
Scanning Saved Documents
Opening...
Light Crafts JAI Library - 02/05/07
Unexpected error in DocumentReader.read()
java.lang.ExceptionInInitializerError: null
/home/berbmit/DSC_0929_lzn.jpg reading metadata java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
    at com.lightcrafts.image.types.JPEGImageType.getXMP(JPEGImageType.java:620)
    at com.lightcrafts.image.types.JPEGImageType.readMetadata(JPEGImageType.java:763)
    at com.lightcrafts.image.ImageInfo.getMetadata(ImageInfo.java:300)
    at com.lightcrafts.ui.metadata2.MetadataStack.setImage(MetadataStack.java:49)
    at com.lightcrafts.ui.metadata2.MetadataStack.<init>(MetadataStack.java:34)
    at com.lightcrafts.ui.metadata2.MetadataScroll.setImage(MetadataScroll.java:55)
    at com.lightcrafts.app.ComboFrame.setImage(ComboFrame.java:410)
    at com.lightcrafts.app.ComboFrame.selectionChanged(ComboFrame.java:421)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:41)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.ImageBrowserMulticaster.selectionChanged(ImageBrowserMulticaster.java:42)
    at com.lightcrafts.ui.browser.view.AbstractImageBrowser.notifySelectionChanged(AbstractImageBrowser.java:852)
    at com.lightcrafts.ui.browser.view.ImageBrowserSelectionModel.setLeadSelected(ImageBrowserSelectionModel.java:27)
    at com.lightcrafts.ui.browser.view.AbstractImageBrowser.setSelectedFiles(AbstractImageBrowser.java:514)
    at com.lightcrafts.app.ComboFrame$8.run(ComboFrame.java:1122)
    at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:251)
    at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
    at java.awt.EventQueue.access$200(EventQueue.java:103)
    at java.awt.EventQueue$3.run(EventQueue.java:694)
    at java.awt.EventQueue$3.run(EventQueue.java:692)
    at java.security.AccessController.doPrivileged(Native Method)
    at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
    at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
    at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
    at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
    at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
    at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
    at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
java.lang.NoClassDefFoundError while fetching preview for /home/berbmit/20140521_171720.jpg: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
java: symbol lookup error: /opt/lightzone/libLCMS.so: undefined symbol: cmsOpenProfileFromMem
 

ktgw0316
Re:

Hello berbmit,

I've just published a new package to fix the libLCMS.so issue. Please update your package and try again.

You can check version for the currently installed package with "dpkg -p lightzone" command. Older package version is "4.1.0~beta10-0obs1" and newer one is "-0obs2".

 

This issue is only on Debian and xUbuntu packages, if my understanding is correct.

 

Masahiro from Dev-team

berbmit
Amazing ... thanks for the

Amazing ... thanks for the incredible rapid response.  Problem fixed!  Weekend workflow restored!

Much thanks

 

rlhobday
Error msg on startup: Couldn't link with native library: "LCTIFF

4.1.0~beta10-0obs2 with Linux Mint 17 64bit

This error message pops up on startup,

Couldn't link with native library: "LCTIFF

/opt/lightzone/libLCTIFF.so: libtiff.so.4: cannot open shared object file: No such file or directory

 

If I dismiss it the program then runs fine and allows me to save a .jpg file.

But not to convert to .tif

Any thoughts?

 

 

ktgw0316
For Mint 17, please make sure

For Mint 17, please make sure that you are using a package from "xUbuntu_14.04" repository. That package will use libtiff.so.5 provided by libtiff5 package instead of libtiff.so.4.

 

 

 

rlhobday
Many thanks, that was the

Many thanks, that was the problem.  All fine now.

Thanks for all you hard work.

berbmit
Oops ... premature conclusion

My prior comment was maybe a bit too quick of the mark, apologies, I should have tested more thoroughly. 

Lightzone now starts, runs, edits, but doesn't save.  No crash, just won't save and gives and on screen error widow of the following:

Couldn't save to /icydock/big/personal/MyPhotos/X-T1/2014/2014-06-13/LZExport976214668450531495.tmp

java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil

dpkg -p lightzone shows this is Version: 4.1.0~beta10-0obs2

Running from the command line, I also see this on startup:

Starting LightZone version 4.1.0 beta10 ...
with options :
This is LightZone 4.1.0~beta10 ()
Verifying Libraries
Initializing Engine Utilities
Max Memory: 7462191104
Total Memory: 251658240
Running on 8 processors
Allocating 0MB for the image cache.
Loading Classes
Scanning Color Profiles
Restoring Preferences
Starting Logging
Scanning Saved Documents
Opening...
Light Crafts JAI Library - 02/05/07
Unexpected error in DocumentReader.read()
java.lang.ExceptionInInitializerError: null
Unexpected error in DocumentReader.read()
java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
Unexpected error in DocumentReader.read()
java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
Unexpected error in DocumentReader.read()
java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
Unexpected error in DocumentReader.read()
java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
Unexpected error in DocumentReader.read()
java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
/icydock/big/personal/MyPhotos/X-T1/2014/2014-06-13/DSCF2656_lzn.jpg reading metadata java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil

 

Thanks for any pointers on how to fix.

-b

 

 

Rich52
Lightzone 4.1.0-beta10-0obs2

Starting LightZone version 4.1.0 beta10 ...
with options :
This is LightZone 4.1.0~beta10 ()
java.lang.NoSuchMethodError: org.jvnet.lafwidget.menu.MenuSearchWidget.showSearchPanels()V
        at org.jvnet.substance.SubstanceMenuBarUI.showSearchPanels(SubstanceMenuBarUI.java:88)
        at org.jvnet.substance.SubstanceLookAndFeel.initialize(SubstanceLookAndFeel.java:3932)
        at javax.swing.UIManager.setLookAndFeel(UIManager.java:535)
        at org.jvnet.substance.SubstanceLookAndFeel.setSkin(SubstanceLookAndFeel.java:4996)
        at com.lightcrafts.ui.LightZoneSkin.getLightZoneLookAndFeel(LightZoneSkin.java:295)
        at com.lightcrafts.platform.linux.LinuxPlatform.getLookAndFeel(LinuxPlatform.java:48)
        at com.lightcrafts.platform.linux.LinuxLauncher.main(LinuxLauncher.java:35)

I'm running Kubuntu  14.04 / kernel 3.13-33 I get the following error message after installing and running LightZone. A Java window opens up indicating an internal error.  Beta 4.1-beta 9 worked perfectly. . . Must be some type of Java issue in so far as I can tell. Any help would be appreciated. 

 

Richard ;)

Rich52
Screen shot of startup of LZ4.1.0-beta10 (Oob2)

Here is the screen shot of the startup of the latest on my computer if this helps anyone. . . . 

Rich52
Lightzone Stable release still works. . . .

I removed the beta 10 program from my system and reinstalled the 'stable' release 4.1.0 of Lightzone and everything still works as expected.  We'll have to wait and see I guess until the bugs get worked out. . . 

 

Richard :)

Francois_C
Beta 10 installed today from

Beta 10 installed today from PPA on Ubuntu Studio 14.0.4 64-bit:

Error while converting to JPEG (even sidecar files).

java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil

hansemann
can't get beta 10 up and running on debian unstable

can't get the beta 10 to work on my debian unstable.

Tried it with different java versions and compiling the source code here on my box

..........nothing

would be happy for every tip

 

Starting LightZone version 4.1.0 beta10 ...
with options :
This is LightZone 4.1.0~beta10 ()
Überprüfe Bibliotheken
Initialisiere Funktionseinheiten
Max Memory: 7495745536
Total Memory: 252706816
Running on 6 processors
Allocating 0MB for the image cache. Profile Data
found sRGB IEC61966-2.1
Malformed display profile at (sRGB default)
Lade Klassen
Durchsuche Farbprofile
Eigenschaften wiederherstellen
Starte Logging
Durchsuche gespeicherte Dokumente
Öffne...
Light Crafts JAI Library - 02/05/07
Exception in thread "AWT-EventQueue-0" java.lang.RuntimeException: Fehler beim Initialisieren des Browsers
at com.lightcrafts.app.ComboFrame.initImages(ComboFrame.java:1036)
at com.lightcrafts.app.ComboFrame.showFolder(ComboFrame.java:361)
at com.lightcrafts.app.ComboFrame.<init>(ComboFrame.java:205)
at com.lightcrafts.app.Application.createNewComboFrame(Application.java:1495)
at com.lightcrafts.app.Application.openEmpty(Application.java:566)
at com.lightcrafts.app.Application$10.run(Application.java:2194)
at java.awt.event.InvocationEvent.dispatch(InvocationEvent.java:312)
at java.awt.EventQueue.dispatchEventImpl(EventQueue.java:733)
at java.awt.EventQueue.access$200(EventQueue.java:103)
at java.awt.EventQueue$3.run(EventQueue.java:694)
at java.awt.EventQueue$3.run(EventQueue.java:692)
at java.security.AccessController.doPrivileged(Native Method)
at java.security.ProtectionDomain$1.doIntersectionPrivilege(ProtectionDomain.java:76)
at java.awt.EventQueue.dispatchEvent(EventQueue.java:703)
at java.awt.EventDispatchThread.pumpOneEventForFilters(EventDispatchThread.java:242)
at java.awt.EventDispatchThread.pumpEventsForFilter(EventDispatchThread.java:161)
at java.awt.EventDispatchThread.pumpEventsForHierarchy(EventDispatchThread.java:150)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:146)
at java.awt.EventDispatchThread.pumpEvents(EventDispatchThread.java:138)
at java.awt.EventDispatchThread.run(EventDispatchThread.java:91)
Caused by: java.lang.ExceptionInInitializerError
at com.lightcrafts.image.types.TIFFImageType.getLZNDocumentImpl(TIFFImageType.java:535)
at com.lightcrafts.image.types.TIFFImageType.getTrueImageTypeOf(TIFFImageType.java:332)
at com.lightcrafts.image.ImageInfo.determineFinalImageType(ImageInfo.java:560)
at com.lightcrafts.image.ImageInfo.getMetadata(ImageInfo.java:301)
at com.lightcrafts.image.types.CanonTIFFRawImageProbe.getTrueImageTypeOf(CanonTIFFRawImageProbe.java:37)
at com.lightcrafts.image.types.TIFFImageType.getTrueImageTypeOf(TIFFImageType.java:326)
at com.lightcrafts.image.ImageInfo.determineFinalImageType(ImageInfo.java:560)
at com.lightcrafts.image.ImageInfo.getImageType(ImageInfo.java:267)
at com.lightcrafts.ui.editor.DocumentReader.read(DocumentReader.java:65)
at com.lightcrafts.app.Application$8.getImageFile(Application.java:1768)
at com.lightcrafts.ui.editor.assoc.DocumentDatabase.readFile(DocumentDatabase.java:215)
at com.lightcrafts.ui.editor.assoc.DocumentDatabase.readDirectory(DocumentDatabase.java:249)
at com.lightcrafts.ui.editor.assoc.DocumentDatabase.addDocumentDirectory(DocumentDatabase.java:151)
at com.lightcrafts.app.ComboFrame$5.run(ComboFrame.java:1015)
at com.lightcrafts.utils.thread.CancelableThreadMonitor.run(CancelableThreadMonitor.java:96)
Caused by: java.lang.IllegalArgumentException: Unknown attribute indent-number
at com.icl.saxon.TransformerFactoryImpl.setAttribute(TransformerFactoryImpl.java:465)
at com.lightcrafts.utils.xml.XMLUtil.<clinit>(XMLUtil.java:440)
... 15 more

hansemann
problem solved

I've downloaded and builded "oracle-java8-jre" for my debian unstable....all problems are gone now!

Photonoxx
I've Ubuntu 14.04 64bits, and

I've Ubuntu 14.04 64bits, and personally LZ start, edit and save without apparent issue.

 

The lone thing, is the black and green rectangle on fuji X RAF matter describe in an other thread 

 

Personally, I think I use OpenJDK7, may be if you used Oracle java 7 it was the source of the problem ? 

hansemann
no, I've used openjdk7 the

no, I've used openjdk7 the whole time and tried openjdk8 also. On Debian unstable there seem's something to be missing or is at uncomon point, so lightzone beta 10 did not find it. Maybee it was a local problem on my computer. I've had no problems with beta 8 or 9, but after switching to beta 10, I got the problems - If I switched back to beta 9 or the stable, no problems at all.

hansemann
arghhh....after switching to

arghhh....after switching to another directory with images and a new start from lightzone, I got the same errors as before.

so forget what I've said......

ktgw0316
XSLT processors

Hansemann, I finally found that I have same problem as yours when saxon or xalan is installed. Please remove "libsaxon-java" and "libxalan2-java" packages from your machine and check if it solve the problem.

Anyway, I found a workaround for this bug and modified the code for next beta.

 

Masahiro

hansemann
WOW.....

WOW.....

thank's Masahiro......it works!!!

PhotosByJames
cannot save work

When trying to save work, a confirm dialog box comes up with:

Couldn't save to
/mnt/Data/Photos/2014/August/LZExport6258726780138108442.tmp

java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil

I'm using Mint 17

Here's the running particulars:

Starting LightZone version 4.1.0 beta10 ...
with options :
This is LightZone 4.1.0~beta10 ()
Verifying Libraries
Initializing Engine Utilities
Max Memory: 1666711552
Total Memory: 56623104
Running on 2 processors
Allocating 0MB for the image cache.
Not a valid color profile at /usr/share/color/icc/TR006.ti3: Invalid ICC Profile Data
Not a valid color profile at /usr/share/color/icc/FOGRA39L.ti3: Invalid ICC Profile Data
Not a valid color profile at /usr/share/color/icc/FOGRA28L.ti3: Invalid ICC Profile Data
Not a valid color profile at /usr/share/color/icc/FOGRA40L.ti3: Invalid ICC Profile Data
Not a valid color profile at /usr/share/color/icc/TR003.ti3: Invalid ICC Profile Data
Not a valid color profile at /usr/share/color/icc/TR002.ti3: Invalid ICC Profile Data
Not a valid color profile at /usr/share/color/icc/TR005.ti3: Invalid ICC Profile Data
Not a valid color profile at /usr/share/color/icc/FOGRA29L.ti3: Invalid ICC Profile Data
Not a valid color profile at /usr/share/color/icc/FOGRA30L.ti3: Invalid ICC Profile Data
found sRGB IEC61966-2.1
Malformed display profile at (sRGB default)
Loading Classes
Scanning Color Profiles
Restoring Preferences
Starting Logging
Scanning Saved Documents
Opening...
EventThread blocked for 2.000 seconds
Light Crafts JAI Library - 02/05/07
EventThread blocked for 4.003 seconds
/mnt/Data/Photos/2014/August/2014-0818/IMG_2822a.JPG reading metadata java.lang.ExceptionInInitializerError
/mnt/Data/Photos/2014/August/2014-0818/IMG_2815a.JPG reading metadata java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
/mnt/Data/Photos/2014/August/2014-0818/IMG_2816a.JPG reading metadata java.lang.NoClassDefFoundError: Could not initialize class com.lightcrafts.utils.xml.XMLUtil
EventThread blocked for 2.000 seconds

Francois_C
This was definitely a buggy

This was definitely a buggy version;)

I reverted to beta 8, the only one I had a .deb copy of, and I'm looking forward to beta 11...

hansemann
After my beta 10 is finaly

After my beta 10 is finaly running, I'm realy happy with it..it seems to me, that it run's smoother  and better as before.

A Beta is work in progress and there seems to be some changes under the hood with this version.

One thing I noticed after my beta is running is, that some problems may come from the default java we are using.

For example, with the openjdk 7 or 8 which is the default in debian, lightzone crashes on my computer when I try to open a raw DNG file produced by vuescan,

if I use Lightzone with oracle-java then there is no problem to open this file......

 

ktgw0316
lightzone crashes on my

lightzone crashes on my computer when I try to open a raw DNG file produced by vuescan,

I'd like to look into the sample DNG file. Could you upload it somewhere I can download?

hansemann
I've uploaded a example DNG

I've uploaded a example DNG to

https://www.wuala.com/jo-hennes/Public/

there is only one file in the directory. I don't remember when I first get problems with my  vuescan DNG's and lightzone, it maybe

5 or 6 weeks in the past, so that problem is not related to the Beta-10.

The problem only exist if I use openjdk and goes away if I use the oracle-Java with lightzone.

The version from openjdk on my debian is 7u65-2.5.1-5 and in my opinion it is a bug in the debian java package...or in the openjdk upstream version

Francois_C
This is a large DNG for a

This is a large DNG for a very small kitten! cute!

I can open and convert it with beta 8 using the latest version of dcraw OpenMP multithread by Masahiro and openjdk 7 on Linux.

hansemann
hello Masahiro,

hello Masahiro,

wanted only to report back that the beta 11works with both java's again....

...good work...thanks

ZaphodBB
Same problem of the OP here

Same problem of the OP here on Ubuntu 14.04 64, is there any way to install a previous version?

hansemann
you can of course install the

you can of course install the stable version, or if  you have the right libararys you can try to build a development snapshot  . It should be relative easy . On debian you do it with 'debuild' and I think it should be the same with ubuntu. You can find older development snapshots under sourcecode on this page. goto 'branches' -> klick on 'tags' and than you can choose a older beta

........you are not the zaphod from bzflag ???

 

greetings hans

bameylan
Lightzone don't start

Hi,

after upgrading my Lightzone to 4.1.3 (the previous version work fine), no start, but this message:

Starting LightZone version 4.1.3 ...
with options :
Fontconfig warning: "/etc/fonts/conf.d/50-user.conf", line 14: reading configurations from ~/.fonts.conf is deprecated. please move it to /home/bameylan/.config/fontconfig/fonts.conf manually
This is LightZone 4.1.3 ()
java.lang.NoSuchMethodError: org.jvnet.lafwidget.menu.MenuSearchWidget.showSearchPanels()V
        at org.jvnet.substance.SubstanceMenuBarUI.showSearchPanels(SubstanceMenuBarUI.java:88)
        at org.jvnet.substance.SubstanceLookAndFeel.initialize(SubstanceLookAndFeel.java:3932)
        at javax.swing.UIManager.setLookAndFeel(UIManager.java:538)
        at org.jvnet.substance.SubstanceLookAndFeel.setSkin(SubstanceLookAndFeel.java:4996)
        at com.lightcrafts.ui.LightZoneSkin.getLightZoneLookAndFeel(LightZoneSkin.java:295)
        at com.lightcrafts.platform.linux.LinuxPlatform.getLookAndFeel(LinuxPlatform.java:57)
        at com.lightcrafts.platform.linux.LinuxLauncher.main(LinuxLauncher.java:36)

 

I understand that I must move somewhat (a line, or a file?) to /home/bameylan/.config/fontconfig/fonts.conf... but is tha all what I've to do?

Thanks in advance for your advices.

Cheers.

Bernard