Light zone crashes in windows when editing


Posting rules: It shouldn't need saying, but... play nice. Please keep your discussions civil. You can disagree, just don't be disagreeable. And, of course, all of the usual stuff like no spamming. Tex adds: I'll be rigorously enforcing this as we go along. We're probably going to be a small community in a little lifeboat, so we can't have members at each others' throats. This is for the sake of the project as a whole. So when you post, pretend you're speaking in person with your very wealthy auntie who has always treated you wonderfully and currently lists you prominently in her will. I won't be tossing anyone out of the forums because we are all in this together (except spammers: immediate membership cancelation), but I'll delete suspect posts right away.


16 posts / 0 new
Last post
fagopher
Light zone crashes in windows when editing

I just installed it and when I try to edit any RAW file It just throws errors on temp files. I tried Editing a jpeg file and the editor opened this time but it just hanged and there is no way to close the program.

Before this I had the trial version 3.x (I think 3.9) and de-installed and re-installed thi one. Has anybody using it successfully ?

mrapollinax
I've been using it with no

I've been using it with no issues on Win 7 x64 Pro and Ultimate. I'm guessing your camera RAW files might not be supported? As with anything more information you can provide on your situation the better people might be able to help you.

 

1. What OS version are you running?

2. Are your files stored on a local or network drive?

3. What camera are your RAW files from?

4. Does the browsing window work?

 

 

fagopher
mmm.. this is very strange...

mmm.. this is very strange...

 

I tested with few photos in RAW and a scanned photo in jpg. RAW produced errors in tmp files. while the scanned photo caused it to just hang.

 

I tried it again and the scanned phot made it hang again, tried other jpgs and they worked.

Tried again the raw and it worked this time. Not sure if it was a specific photo or if the system was running some background process (since it was a fresh new instalaltion). It seems it is now working.. I need to test with more photos and see how it behaves.

 

Btw. My camera is a Nikon 5000, .NEF files.

 

Thanks and sorry should hav etested it a few more times before posting.

 

 

tex
No, you did the right thing

No, you did the right thing to report it.  I've been using LZ since the beginning, 2006, and today it hung up on me, also Win 7, for the first time since I've been using Win 7 (2 years, easy).  It got crochety,  It happens.  That's why we save save save!

laptopray
Freezes

Downloaded LightZone 4 today onto my Linux Mint 14 machine (64 bit, Cinnamon).

I like the way it works, and it does a good job but, after I have completed one image and saved it, I always have a problem with the subsequent images unless I close, the re-open LZ first.

The problem is not in the processing, but in saving - it can't do it.  Not only that but, although I can do some more things with the program, it will not allow me to close it.  The only way I have found to close the program is to turn off the computer - most things on the screen are frozen, including the OS shutdown.

Yesterday, I downloaded LZ onto a Debian 7 machine (32 bit, XFCE).  Had exactly the same problem there.  Both versions were downloaded using the correct sources for the different OS's.

Where do I go from here?  I had been using Aftershot Pro, but I'd prefer not to go back to it - no updates for ages.

Any ideas?

tex
This is a new problem---we

This is a new problem---we haven't seen this one yet, no other reports that i know of.  I'm not Linux, so no help there---hopefully one of our Linux users will see the post----trouble is, it's not well identified in the title as a Linux problem, and it's in a thread about Windows crashes.

Also, please check your preferences and look at what's dialed up for saving & etc.

Picasso
Hi,

Hi,

 

I tried to reproduce your issue. I am using Mint 14, Mint 15 and Debian, all of them fully updated. I could not reproduce the issue you are having.

Have you tried to start LZ from a terminal? Are there any error msg? any chance you ran a strace?

buzzb
I have the same problem.

I have the same problem. Either it freezes solid during editing or if I make it through the edits, it hangs on saving the edited file and won't shut down (I shut it down through the Task Manger).

alisyedw
.    

.

 

 

buzzb
Slow, freezes

I just installed the latest version (plenty of RAM, etc.). With the first install (64 version, Windows 8.1), it was so slow, then got stuck on saving my file, so I uninstalled and re-installed--it was better, but then it froze solid. I can't even close the window, so I'll have to restart or uninstall to shut it down.

lintujuh
I'm not sure in which thread to comment

I noticed also on my new Win10/64 freeze in LZ. I managed to pinpoint it to following conditions

  • it never froze on a RAW (at least .CR2 or .ORF)
  • it never froze on JPG when I selected a Style from the top menu
  • it froze on JPG when I moved my mouse over the Style pane (no need to select a style)
  • it froze on JPG even if I had first selected a tool (e.g. Zones) or a style from the menu and moved my mouse over the Style pane

The same thing happens also on my fresh Ubuntu 17.10

Edit: When LZ freezes it uses 100% of one core. In Linux you can the monitoring shows it clearly, in Win the CPU% is around the share of a single core.

-Juha

buzzb
It has to be something within

It has to be something within Lightzone--I installed RawTherapee, edited some photos and saved them with no problems. I think LZ is a betetr program, but...

Nuno Mendonca
LightZone freezes while saving

I get the same thing on Windows 10 64bit.

LightZone freezes while saving, any file, any format, any type of change.

 

dFlyer
Freezes in edit when a style

Freezes in edit when a style is selectec on Window 10's Creative addition with all recent update on an HP with AMD 64 Bit processor. 

larshenrikoern
New Windows build

Hi

 

Try to download the Windows installer again. Several issues has been fixed. Use the one that matches your windos (64 or 32 bit). Uninstall LZ and install from the new installer. This might very well solve your problem.

 

Haave a nice day

dFlyer
Downloaded the most recent

Downloaded the most recent window build and now everythings appears to be working correctly.

Thank you